NAT error

Discussion in 'General Software' started by roy92, Dec 27, 2006.

  1. roy92

    roy92 CSS HAXOR

    Likes Received:
    0
    Trophy Points:
    0
    hi

    i keep gettin nat errors in azureus. ive opend port 51234 as instructed by portforwarding.com. but i stil get it.

    any suggestions would be great
     
  2. sabashuali

    sabashuali Ani Ma'amin

    Likes Received:
    6
    Trophy Points:
    38
    Hi

    Check here - https://www.grc.com/x/ne.dll?bh0bkyd2 while Azureus is running, to see whether your port is truly opened.

    Once you have loaded the web page, click on 'proceed', enter the port number in the empty field and click on the 'User Specified Custom Port Probe' button.

    If the report does not say 'open', then your post isn't! Back to the drawing board. Is the port 'forwarded by request' or 'always'?

    Just to let you know that I also run into problems from time to time. Restarting Azureus, normally solves the problem. For me anyway...
     
  3. roy92

    roy92 CSS HAXOR

    Likes Received:
    0
    Trophy Points:
    0
    wat if it says stealth?
     
  4. sabashuali

    sabashuali Ani Ma'amin

    Likes Received:
    6
    Trophy Points:
    38
    It means that the port is definitly not forwarded.
    Are you using a software wall or a hardware of sort, i.e. router or a PC?
     
  5. roy92

    roy92 CSS HAXOR

    Likes Received:
    0
    Trophy Points:
    0
    yeah.. sorry ... forgot to put that.

    ok, ive got a dlink DI-524 wireless router and the windows firewall. is tehre a way to disable nat, or the firewall? coz im getting medium speeds (max around 33kb/s but averages around 15 and my connection is a 512k adsl)

    ps. ive said this before, but i did exactly wat they said to do in portforwarding.com, how come its not working?
     
  6. sabashuali

    sabashuali Ani Ma'amin

    Likes Received:
    6
    Trophy Points:
    38
    Right.... before you start delving into the router's settings, can you just confirm whether you are using a software wall as well?

    Where/how did you forward the port?
    Via the router's rules or the software rules?
     
  7. roy92

    roy92 CSS HAXOR

    Likes Received:
    0
    Trophy Points:
    0
    no software

    in the dlink settings, i went into virtual server entered teh ports. so it must be the routers rules, i also did it in sp2 firewall jst in case.

    hope this helps
     
  8. sabashuali

    sabashuali Ani Ma'amin

    Likes Received:
    6
    Trophy Points:
    38
    Aha! First you need to decide which one you want to use! You either embrace M$-XP, build in, software firewall or the one build in to your router.

    My suggestion is to disable the SP2 firewall. It is my understanding that it is not 'all that' anyway.

    Once you have done that, try again.
    I am not using D-Link so cannot comment on how to do port forwarding.

    This is how I do it in Netgear (once logged in to the 'virtual server'):
    1. Create a new service - chose TCP/UDP or both, then entre your port (start and end port are the same if you are using just one port.).
    2. Add an inbound service - chose the newly added service created in the previous step. Then I chose 'Allow by request, otherwise block' and send to a new LAN IP address (something like 192.168.0.X).

    And that's that.

    As I said before, I have stopped using 'softwalls' since I got my router.
    When I do get a NAT error, which hardly ever happen (a bit tlike huricaines in Hereford), I normaly restart the application and it seems to work....
     
  9. roy92

    roy92 CSS HAXOR

    Likes Received:
    0
    Trophy Points:
    0
    ok, so right now I've got port 6112 open for udp and tcp but I've got two spaces labelled private and public, do I put 6112 into those 2 spaces?
     
  10. sabashuali

    sabashuali Ani Ma'amin

    Likes Received:
    6
    Trophy Points:
    38
    I had a very quick read through your manual so this is definitely not an expert advice!!!

    I think you will need to put the port number in both fields to properly open the desired port.
     
  11. roy92

    roy92 CSS HAXOR

    Likes Received:
    0
    Trophy Points:
    0
    thanks so much for your replies! but i've done that and it still shows that yellow smiley face.
     
  12. sabashuali

    sabashuali Ani Ma'amin

    Likes Received:
    6
    Trophy Points:
    38
    I will be frank with you, I always found Azureus a tad troublesome and always ended up using Ktorrent (KDE client). I am not sure the yellow smiley means your port is not open. At the bottom of the screen you have the three lights: Ratio, NAT and 'users connected'. What is the status of those lights. Also, have you tried other torrents? And what does the tracker status say?
     
  13. thoonie

    thoonie hmmm....

    Likes Received:
    0
    Trophy Points:
    16
    can you test your port using canyouseeme.org, open azureus first.
     
  14. roy92

    roy92 CSS HAXOR

    Likes Received:
    0
    Trophy Points:
    0
    the ratio is yellow, the nat is grey and teh user is green

    no i havent used any others

    and in canyouseeme.org, it couldnt find the service
     
  15. sabashuali

    sabashuali Ani Ma'amin

    Likes Received:
    6
    Trophy Points:
    38
    regardless of any problems you might have - ratio, unless you are very generous with your bandwidth, will usualy be yellow or red. NAT is bad if it goes red or yellow. It should be green but can sometimes stay grey for quite a while.

    By the way, now that you have disabled the SP2 firewall and, hopefully, forwarded the port, what report do you get from Home of Gibson Research Corporation for this port, when Azureus is running?
     
  16. roy92

    roy92 CSS HAXOR

    Likes Received:
    0
    Trophy Points:
    0
    i missed something...firewall is red
     
  17. roy92

    roy92 CSS HAXOR

    Likes Received:
    0
    Trophy Points:
    0
    just to make something clear, i've got 512kbs download speed, how fast should i expect 1 download to go?
     
  18. Crusha19

    Crusha19 Aspiring Poker Player

    Likes Received:
    1
    Trophy Points:
    18
    I would maybe switch to Utorrent (ĀµTorrent - Powerful BitTorrent Client) I have both but i tend to use utorrent more, it loads much faster. My router was being POS so instead of doing port forwarding i just enabled UPnP. This fixed my NAT problems and I now get 150kb/s. Hope this helps
     
  19. roy92

    roy92 CSS HAXOR

    Likes Received:
    0
    Trophy Points:
    0
    umm.... can u help me setup utorrent? wat is your connection speed?
     

Share This Page