"Network Cable Unplugged" After Reformat

Discussion in 'Networking and Computer Security' started by Putter, Apr 1, 2011.

  1. Putter

    Putter Geek

    Likes Received:
    Trophy Points:
    My roommate's laptop hard drive busted and he took it to the Geek Squad or whatever. A week and an absurd amount of money later it comes back with a reformatted Win7 install, but now when he tries to use the wired internet it says the cable is unplugged. The cable is definitely good, it works on the X360. The modem is fine, my computers both work on their lines.

    I've tried a few things, got 2 sets of drivers (the default, and a Rollback one) that didn't work. I tried playin with the Speed and Duplex and tried all the options (10mbps/100mbps half and full, etc.) to no avail.

    BTW it's an ASUS laptop with a Realtek 8168C NIC, operating on Windows 7.

    Wondering if anyone has any ideas on how to get this running.
  2. Anti-Trend

    Anti-Trend Nonconformist Geek

    Likes Received:
    Trophy Points:
    Have you tried (re)installing the NIC's drivers?

Share This Page