Razer Megalodon connection problem

Discussion in 'Sound Cards and Speakers' started by Martin Vang Rasmussen, Jun 19, 2011.

  1. Martin Vang Rasmussen

    Martin Vang Rasmussen Geek Trainee

    Likes Received:
    Trophy Points:
    Hi there everyone.
    New here and I came here because I suddenly got this annoying problem with my Razer Megalodon headset.
    When I bought it, everything was fine. It worked fine, and I was a happy man.

    But now I've run into some problems.
    When I plug it into the usb port, the only thing that lights up is the 7.1 light. everything else is dark and there's no sound and the mic doesn't work either.

    If anyone can help me out i will be gratefull! :)

  2. cube_

    cube_ Mega Geek

    Likes Received:
    Trophy Points:
    Since you don't need to install drivers for this device, we'll have to confirm other configurations:

    In Device Manager, are there any items that need attention under "Sound"? Is there a red x on the Volume Control? How about re-installing the audio driver which can be found on your motherboard's manufacturer website?
    Also, since this headset is a USB plug and play device, you'll have to make sure that the USB ports in front of your case are enabled via BIOS. If the headset isn't connected via the front USB ports and is plugged into the back panel, then download the latest chipset drivers as well from your motherboard's manufacturer website.

    What O/S are you running? When you connect or disconnect the headset, do you get a notification that the device is connected/disconnected? Have you tried using the headset on another computer? Worst case, the headset wen't bad.

    Edit: Found this video on youtube. If the above methods don't work, you can try upgrading the firmware.
  3. m1dnight_dreary

    m1dnight_dreary Geek Trainee

    Likes Received:
    Trophy Points:
    I'm having the same problem. Tried updating all the motherboard drivers, but no dice. I've just rebuilt my comp (still using the x58 mobo though) and can't get the headset working again - Windows doesn't even recognise it. Did you manage to get yours working Martin?

Share This Page