SiS 7012 Audio Adapter

Discussion in 'Sound Cards and Speakers' started by Andrew So Amazen, Oct 4, 2011.

  1. Andrew So Amazen

    Andrew So Amazen Geek Trainee

    Likes Received:
    0
    Trophy Points:
    1
    Just signed up here and normally would never really signup for help, rather I would be offering help but at wits end i'm drawing no results with extensive research and attempts...

    Recently I had XP installed, sound worked golden then I did a fresh install from a format to windows 7...
    At first, the install did not install my network adapter (onboard, not wireless) so I used my girlfriends laptop to look into the drivers...Upon googling it and learning there was no SiS-900 ethernet adapter drivers for windows 7..After looking a little more I found a site that said use the XP drivers and they would work for the device even though I was running Windows 7. I decided to give it a try and it worked, problem solved!

    -Now I'm on the internet and every other device is working properly! (much to my own distraction) I didn't notice the uninstalled sound card! So, taking the fact windows 7 had not installed it upon installing the OS itself, I began the driver hunt yet again, but this time for my SiS 7012 (Gigabyte manufacturer???) but to no avail. Keeping in mind I have the specs for my entire PC and already know the make of the sound card I'm searching for drivers for, it's not a case of "Whats my soundcard?"...

    My problem is, much like the SiS-900 ethernet adapter issue I attempted the same thing for he sound card drivers, using the XP drivers.....NOPE!......I have google'd this numerous times, and have tried so many different things from various suggestions and nothing has worked...

    My FURTHEST bit of progress I DID make with this sound card and any drivers were the Realtek AC'97..Though, they installed the sound card and it was no longer an unknown device, it produced absolutely NO sound from my computer..Thus, I uninstalled the drivers for it, re-detected it as an unknown and now need the drivers!!!

    I cannot seem to find anything indicating drivers are available for this sound card BEYOND vista..

    I have attached a .txt of my HWiNFO32 log to provide my full system specs and make any attempts at help, far less complicated and immediate, thanks again for your time and I hope to hear back A.S.A.P as it is very irritating playing games and watching videos I cannot hear!!!!

    P.S I'm not a novice computer user by any means, in fact I'm quite good with them and extremely familar, which is why this is throwing me off so much, unless of course it just boils down to a compatibility issue which hopefully there would be a 'work around'..
     

    Attached Files:

  2. Andrew So Amazen

    Andrew So Amazen Geek Trainee

    Likes Received:
    0
    Trophy Points:
    1
    I thought this was a technical support forum?.....I get 8 views and not 1 idea or suggestion, c'mon guys!!! I really need a hand here!!!
     
  3. Wildcard

    Wildcard Big Geek

    Likes Received:
    26
    Trophy Points:
    28
    Hi,

    In your post you mentioned there is a windows Vista driver. I would definitely try that one if you have not already as 7 and vista seem to have some compatibility between their drivers.
     
  4. M_Kincy

    M_Kincy Geek

    Likes Received:
    7
    Trophy Points:
    18
    Does your graphics adapter have an HDMI output? If so its very possible that win 7 set it as your default sound device. Check in control pannel/hardware and sound/manage audio devices.
     
  5. Ghostman 1

    Ghostman 1 Moderator Staff Member

    Likes Received:
    85
    Trophy Points:
    48

Share This Page