3rd Party USB drivers for NT4

Discussion in 'Drivers and Firmware' started by megamaced, Dec 21, 2005.

  1. megamaced

    megamaced Geek Geek Geek!

    Likes Received:
    0
    Trophy Points:
    36
    As you all know, Windows NT4.0 doesn't support USB. However, I've seen a few 3rd party drivers that claim to add USB functionality to NT4. Unfortunately a) they are not free and b) I haven't found any that claim to support USB flash drives.

    Does anybody know of a USB driver that does work and support flash drives?
     
  2. sabashuali

    sabashuali Ani Ma'amin

    Likes Received:
    6
    Trophy Points:
    38
    Is there a particular reason NT does not support USB?

    Just curious.....
     
  3. megamaced

    megamaced Geek Geek Geek!

    Likes Received:
    0
    Trophy Points:
    36
    USB was being developed towards the end of development for Windows NT. Therefore, it was too late to include support in Windows NT. Unfortunately, they didn't revise this in a later service pack as they did with Windows 95 (which was called Windows 95 OSR1).

    I guess a reason for this was because Windows NT was targeted for business users, who in 1996, were very unlikely to have USB devices - especially flash drives. Besides that, as soon as Microsoft releases an OS, they seem to forget about it and demand people upgrade to the next one!
     
  4. Big B

    Big B HWF Godfather

    Likes Received:
    145
    Trophy Points:
    63
    Offhand, I don't know of much NT support, but you might check out NT Compatible.
     
  5. Anti-Trend

    Anti-Trend Nonconformist Geek Staff Member

    Likes Received:
    118
    Trophy Points:
    63
    One question -- Why in the world are you running NT4?
     
  6. pelvis_3

    pelvis_3 HWF Member For Life

    Likes Received:
    123
    Trophy Points:
    63
    Haha, good point AT, he'd be off running 98SE if anything!
     
  7. megamaced

    megamaced Geek Geek Geek!

    Likes Received:
    0
    Trophy Points:
    36
    Good question! I am dual-booting NT with 2000/XP/2003 for my A+ and MCSE courses. You don't honestly think I am using NT as my main OS do you! :D

    No way! Take that back! NT4.0 may be older, but it is far more secure then Windows 98. After all, it uses NTFS, which makes it more modern. And, its an all-out 32-Bit OS, not running as a shell to MS-DOS.
     
  8. Anti-Trend

    Anti-Trend Nonconformist Geek Staff Member

    Likes Received:
    118
    Trophy Points:
    63
    Comparing the network security of NT4 vs 98 is like comparing the bulletproof properties of a t-shirt vs a sweater. NT4, when it was supported, was much more secure than 98 in most ways. But now, I'm afraid neither really makes the cut. But running a lab with an OS is certainly different than running it full-time. :)
     
  9. megamaced

    megamaced Geek Geek Geek!

    Likes Received:
    0
    Trophy Points:
    36
    Thats a fair comment, but NT4 has other benefits over 98. For example, it has support for dual processors, and has better administrative tools, such as disk management etc.

    I bought my copy on eBay only last month for 99p!! It had never been opened, and included a licence! I had a trip down memory lane because Service Pack 1 comes bundled with IE2 and Media Player 3!
     
  10. Anti-Trend

    Anti-Trend Nonconformist Geek Staff Member

    Likes Received:
    118
    Trophy Points:
    63
    Unfortunately, MS was overly confident in their "contigious" NTFS filesystem, so NT4 didn't include a defragmenter. As a result, NT4 is a lot shorter-lived than later versions of NT (NT5, aka "Windows 2000" and NT5.1, aka "Windows XP"), despite being faster and more stable than either. It also supported only up to DirectX 3.0 with SP6a applied, and had infamously terrible hardware support even in its prime. I know a lot about NT4 since I was an NT administrator of a fairly large NT4 network when I was younger. :O
     
  11. megamaced

    megamaced Geek Geek Geek!

    Likes Received:
    0
    Trophy Points:
    36
    Like all other Windows versions (except maybe XP), I've found them to be very picky about the system they are installed on.

    For example:

    Windows NT:
    Installed fine on my custom built computer, it happily installed all the latest drivers for video card, sound card and modem. No real problems.
    On the other hand, I had a nightmare getting it to work on the Compaq I found in the skip. I had numerous errors, and it refused to install the sound card or ISA modem properly.

    Windows 98
    Didn't like my custom build at all. It regulary crashed and hung on the shut down screen.
    As it happens, it installed flawlessly on the compaq - not even a sqweek!

    Windows 2000
    Oh my god! It refuses to install anything correctly on my custom build. It doesn't like my Geforce2 MX, no matter what drivers I install. It refuses to install my sound card properly, and let's not even talk about my USB2.0 card!
    Of course, on the other hand, it installed flawlessly on an old Compaq Laptop I had.

    So far, only Windows XP has installed OK on all the PCs I have used it with.

    EDIT: I would like to add the following:

    SuSe Linux 9.3
    Installed on my custom build. It detected everything, even the rare onboard C-media sound card - which Windows fails to install. It detected my Hauppauge Digital TV card (although I couldn't get it to work)! It detected my Geforce, although I couldn't get 3D acceleration
     
  12. Anti-Trend

    Anti-Trend Nonconformist Geek Staff Member

    Likes Received:
    118
    Trophy Points:
    63
    Um, Windows 2000 and XP are essentially the same OS, both being NT5, and thus share the same drivers 99% of the time. That includes video drivers. I've never had a hard time getting drivers installed in 2000. No offense intended, but maybe it was operator error?
     
  13. megamaced

    megamaced Geek Geek Geek!

    Likes Received:
    0
    Trophy Points:
    36
    Here are the differences of 2000 and XP in regard to my computer:

    Graphics card:
    Windows 2000 detected it but didn't have the drivers in the database. Believe me when I say I have tried everything! I've updated the chipset drivers, I've updated to DirectX 9 and I've tried all the nVidia drivers. I've even tried the original drivers from the CD that came with the card. I posted about this in another tread, and someone suggested I try some third party Omega drivers. They don't even work! I'm absoluty stumped on this.
    Windows XP detected it and installed it straight off.

    Sound card:
    Both operating systems detected it, but neither had the drivers to install it. Windows XP happily installed it when I provided the correct drivers, where as Windows 2000 refused. Take this for example: Windows makes a click noise when you navigate around Windows explorer. When the Cmedia drivers (specifically for 2000) are installed, that clicking noise doesn't stop once it has started! The only way to turn it off is to restart the PC! Of course, once you start navigating in explorer again, the noise starts again!

    USB2.0 Card based on NEC chipset
    Windows XP installed it (and the attached hub) flawlessly with no problems whatsoever.
    Windows 2000 also detected it and installed it. The only difference being the card and hub don't work whatsoever! I've tried all kinds of drivers with no luck. I can revert to the onboard USB1.1 sockets of course, except they run 50% slower with the drivers for the USB card installed.

    Of course, 90% of errors are caused because of the user! But then again, you only know how to fix Windows, once you know how to break it first!
     

Share This Page