Dell 15R 5520 with i7-3632QM

Discussion in 'Mobile Technology' started by Pavel, Dec 3, 2012.

  1. Pavel

    Pavel Geek Trainee

    Likes Received:
    Trophy Points:
    Hi. i really hope someone can finally help me [​IMG]
    i bought two weeks ago Dell 15R 5520 laptop.
    full spec:
    CPU: intel core i7-3632qm
    memory: 8GB (4x2) DDR3 1600Mhz Nanya Technology NT4GC64C8HG0NS-DI.
    Hard drive 1TB 5400 RPM
    Graphics: AMD Radeon 7670M 1GB and Intel HD 4000.
    15.6" HD 1366*768
    i bought an upgrade from, 16GB (8x2) DDR3 1600mhz Corsair Vengeance CMSX16GX3M2A1600C10.
    the laptop is equiped with Windows 8 Pro legit.
    the laptop worked with the upgrated memory for 3-4 hours then it crashed with BSOD.
    afterwards, any type of reboot was with different BSOD. i put the Nanya both sticks back, and it works like charm.
    put one stick of Corsair and one Nanya it still works fine, but both Corsair same crash.
    i contacted my reatiler of the laptop and he confirmes that it supports 16GB of ram. so is dell itself. and the Dell back and restore program.
    did windows memory diag and came clean of errors for both corsair's. tried to do memtest86+ but it won't load. at all.
    did dell diag via pre-boot system assessment, clean of errors.
    some tech guy advised me to down clock the memory to 1333mhz but i don't know how it can be possible via lack of advanced properties on dell bios, which i updated to latest firmware via dell support site.
    What can i do? please advice me, i going nuts. i need that ram upgrade because of need to run multiple hyper-v machines. [​IMG]
  2. Jan Benedict

    Jan Benedict Geek

    Likes Received:
    Trophy Points:
    So, if I got this right, it won't boot using the two Corsair Vengeance? Try to clear your CMOS
  3. Ghostman 1

    Ghostman 1 Moderator Staff Member

    Likes Received:
    Trophy Points:
    Try removing the battery for ten minutes, then reinstall... Also check your bio's to see if it is the newest one out...
  4. Peldet

    Peldet Guest

    You have to check you bio's setting.. Is there any double installation of battery. I think there is a problem of bio's.. First you check then discuss here.

Share This Page