USB Problem in ACER 4741z

Discussion in 'Windows OS's' started by Dominic Alphonso, Jul 4, 2012.

  1. Dominic Alphonso

    Dominic Alphonso Geek Trainee

    Likes Received:
    Trophy Points:
    Hi, I have an ACER 4741z laptop, with windows 7 loaded onto it. It was working perfectly until a few days ago, when suddenly, all three USB slots stopped working. When I plug in ANY USB device, nothing happens. Even power doesnt go through when I try to charge my phone by USB.
    Heres what I tried uptill now:

    1. Checked BIOS for any changes to the usb settings, but there was no such setting.

    2. Loaded Linux Mint as a live CD to check if the USB ports start working in Linux, they didnt work there too, no power from USB either.

    3. Formatted my laptop, reinstalled windows 7, reinstalled all my drivers, but still no change.

    4. went to Device manager and unchecked the switch off device to save power button, in the properties tab of USB root hub controller (By the way, no question marks in the device manager)

    5. Prayed to God!!! Still didnt work :p

    The funny thing is that the bluetooth controller, webcam and card reader are all working perfectly...everything else is working perfectly too...only all 3 USB ports are not working at all.
    Pls help.

Share This Page